Issue
- The manually imported data in Software Subscriptions (samp_sw_subscription) table gets cleaned/deleted post the "SAM - Import User Subscriptions" scheduled job run, whereas the Software Subscriptions created from the Integration Profile (Office 365) remains undeleted.
https://<<instance_name>>.service-now.com/samp_sw_subscription_list.do
Release
- Instance with Software Asset Management Professional plugin enabled.
Cause
- When the value of the field "Source from integration" (sourced_from_integration) column is "null", then the record gets cleaned during the "SAM - Import User Subscriptions" import job run.
Resolution
- In general, when the "SAM - Import User Subscriptions" scheduled job runs, it will clean out all records in the Software Subscriptions (samp_sw_subscription) table where the value of the field "Sourced from integration" (sourced_from_integration) column is "null".
- "Null" also happens to be the default value of the column, so when importing into the subscription table, the value of "sourced_from_integration" needs to be explicitly set to 'No' to ensure that the records are retained post the scheduled job run.
- This can be done by either setting this value with either a script in the transform map or including the value for the column in the source import file and mapping the value.