Issue
Some times we can see the emails are not delivered to certain users even though it is showing sent in the email table of service now instance
Release
All
Cause
At Service now side if the email status is sent, there is a possibility of failure at destination mail server issue.
Resolution
We need to check with the destination mail admin team by sharing the message-id of the email. You can find a message-id from the email header at Service now side.