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Scheduled jobs are not getting processed during the upgrade - Support and Troubleshooting
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  • Scheduled jobs are not getting processed during the upgrade
KB0790184

Scheduled jobs are not getting processed during the upgrade


3114 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Whenever the instance is upgraded, a few of the scheduled jobs will not get processed.

The jobs which will not process include text index event processor, metric update event processor and report view event processor.

 

Release

Any releases.

Cause

This is expected behavior in the platform.

There is flag call "Upgrade Safe" in every schedule jobs.

If the job is marked as Upgrade Safe (check box of 'Upgrade Safe' is checked), then it will run during the instance is upgraded.

If the job is marked as not Upgrade Safe (check box of 'Upgrade Safe' is not checked), then it will not run during the instance is upgraded. (Like text index event processor, metric update event processor eg.)

Resolution

 

It is not recommended to change the upgrade_safe flag on any record to upgrade_safe=true.

All custom sys_triggers must be marked upgrade_safe=false.

The event processor runs during the database upgrade, however, only email related events are processed.

Email generation for outbound notifications and inbound email processing are both fired from events in the event queue.

After the instance upgrade is complete, all the upgrade unsafe jobs are processed and catch up.


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