Issue
After upgrade, On-Call schedules page is not loading.
Release
Madrid
Cause
Modifications to script include 'OnCallSecurityNG'
Resolution
The behavior seen is due to the customizations to script include 'OnCallSecurityNG':
<instance name>.service-now.com/nav_to.do?uri=sys_script_include.do?sys_id=3f8d56170a0a2c9660fe6df53700fe08
When using the On-call Schedules UI, the 'oncallgroups' scripted REST API is being called:
<instance name>.service-now.com/nav_to.do?uri=sys_ws_operation.do?sys_id=fd9f997dc300030035ae3f52c1d3aeb3
This eventually calls the method 'getManagerAccessForGroups' in script include 'OnCallSecurityNG'. However, do to changes made to this script include the method 'getManagerAccessForGroups' is not found in the script include.
The solution here is to revert 'OnCallSecurityNG' back to the out of box code.