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Planned start, end date/time has no value on the change record. - Support and Troubleshooting
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  • Planned start, end date/time has no value on the change record.
KB0789981

Planned start, end date/time has no value on the change record.


1590 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Planned start, end date/time values are empty and the change record is in closed/completed. The fields are set to mandatory by client-side scripting, then how was the user able to submit the form without filling the values.
The history tab doesn't have any entry regarding the Planned start or end date. 

Cause

The "Request Approval" UI action in the change form once clicked will have to make the fields mandatory and hence user should fill the value. But intermittently, this is not happening.
The UI action is setting the state value and upon the state change, a client script is run which will make the fields mandatory.
This is not working intermittently allowing the user to submit the form without filling the values.

Resolution

Since the issue is not reproducible, we can do 2 things here, use the OOB given the business rule "Mandatory Assignment Group" as a reference and implement the same for planned start end dates which is a before business rule and if the value is empty, abort the action.
With respect to custom client scripts, we can suggest to place log statements as per the logic in the code and monitor the issue to reproduce again. Once it is reproduced we can then check the logs to see if the custom client script was executed as per the code logic.


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