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Incident Module: Affected CI field and tables not updating - Support and Troubleshooting
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  • Incident Module: Affected CI field and tables not updating
KB0789944

Incident Module: Affected CI field and tables not updating


689 Views Last updated : Apr 8, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

When the affected CI tab is updated, we expect the behavior to update the CMDB modules. For example, if I update the tab with an Affected CI, I expect the related cmdb_ci_computer tables record to get updated with the associated incident record. This is not the case as nothing happens after adding the Affected CIs. 

Release

Madrid

Cause

This is the expected behavior the only way to automatically update the related Affected CI on the cmdb_ci_computer table with the Incident record is to select a Configuration Item. Selecting the Configuration Item will automatically associate the Affected CIs to the incident record and then associate the incident record to the related cmdb_ci_computer table record. The Affected CIs and cmdb_ci_computer table records are all dependent upon the Configuration Item not the Affected CI. For example when you add the Incident to cmdb_ci_computer table record manually via related list what you are actually doing is associating the related Configuration Item to the Incident record which is in turn populating the Affected CIs. This is why nothing happens when you manually add an Affected CI because the relationship does not work in reverse.

Resolution

This is the expected behavior in the OOB system. If you want to not have to manually add the Incident to the cmdb_ci_computer tables record you need to use the 'Configuration Item' field instead of trying to pick the Affected CIs.


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