Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Conditions are not created for workflow switch activity automatically for any variable. - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Conditions are not created for workflow switch activity automatically for any variable.
KB0789856

Conditions are not created for workflow switch activity automatically for any variable.


924 Views Last updated : Sep 21, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Choice nodes in switch activity are not coming in workflow automatically for any variable.

Open a workflow and try to add switch activity for a select box variable in the instance, only one condition with always is coming.

The expected behavior is to add all the choices into the condition for the workflow switch activity. 

Cause

The issue is fixed on adding the missing OOB business rules and client scripts.

The below business rule and client script are missing in your instance, so the condition for switch activity is not added.

Create Switch conditions - https://<instance-name>.service-now.com/sys_script.do?sys_id=6a53708b0a000704504ce1f1bd40a3e3

Disable Switch Activity Variables - https://<instance-name>.service-now.com/sys_script_client.do?sys_id=6a1b00cc0a0007045117f8786865a85e

 

Resolution

Adding the business rule and client script to the instance will fix the issue. 

Create Switch conditions - https://<instance-name>.service-now.com/sys_script.do?sys_id=6a53708b0a000704504ce1f1bd40a3e3

Disable Switch Activity Variables - https://<instance-name>.service-now.com/sys_script_client.do?sys_id=6a1b00cc0a0007045117f8786865a85e

 


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.