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In catalog tasks when the "Close All task" button is used, the active field and closed fields are not being updated. - Support and Troubleshooting
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  • In catalog tasks when the "Close All task" button is used, the active field and closed fields are not being updated.
KB0789166

In catalog tasks when the "Close All task" button is used, the active field and closed fields are not being updated.


508 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

In catalog tasks when the "Close All task" button is used, the active field and closed fields are not being updated.

Release

Madrid

Cause

There is a customized script include for the "Close All task" button, Most likely related to the setWorkflow(false) line in the code.

Resolution


The "Close All task" button calls a UI Macro Which calls a UI Script Which calls a Script Include and in that Script Include there is a line about setting the workflow to false. When the workflow for a record is set to false all running processes on that record are stopped which means no more updates from that point on including the closed time. As this is a customization and customizations are not supported by ServiceNow, you will need to debug your own process of closing the tasks because we are not familiar with this process and are not responsible for when it breaks.


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