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Most Recent Discovery field is not being updated by SG-SCCM - Support and Troubleshooting
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  • Most Recent Discovery field is not being updated by SG-SCCM
KB0788806

Most Recent Discovery field is not being updated by SG-SCCM


2747 Views Last updated : Apr 8, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

Customer has an active SCCM integration that runs periodically. The logs indicate there are successful updates and inserts but when you go look at the "Most Recent Discovery" field in the CI record it hasn't been updated.

Cause

Since the records are created by the SCCM integration\transform sets and not by Discovery, the field "Most recent discovery" is not mapped by default.

Resolution

The Service Graph Connector for SCCM does not map this field out-of-box. It does map to source_recency_timestamp on the target record for the last time this object was seen by that external source. So in this case it would be the lastHWscan for SCCM import.

You can map field "Most recent discovery" or any other field of your choice by going to robust transform definition in IntegrationHub ETL. This would be a customization of the Service Graph Connector for SCCM and is outside the scope of support to implement. 

  •  Documentation around using IntegrationHub ETL:

https://docs.servicenow.com/bundle/vancouver-servicenow-platform/page/product/configuration-management/concept/integrationhub-etl.html

  • Documentation around customizations of Service Graph Connectors:

https://support.servicenow.com/kb?id=kb_article_view&sys_kb_id=d0d8fa49db877410be625ac2ca9619f2

 


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