Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Can't use (+) icon to add existing Service Catalog in "Catalogs" - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Can't use (+) icon to add existing Service Catalog in "Catalogs"
KB0788056

Can't use (+) icon to add existing Service Catalog in "Catalogs"


451 Views Last updated : Nov 15, 2023 public Copy Permalink
KB Summary by Now Assist

Issue

Service catalog cannot be added because there is no response when clicking the “+” icon in the "Catalogs" screen.

Release

This happens for any released version of ServiceNow

Cause

The main reason after analyzed the debug log info is the screen is looking for a default catalog sys_id=742ce428d7211100f2d224837e61036d.

It turns out to be OOTB "Technical Catalog", If the customer deleted this OOTB catalog they will have this issue and it will not be resolved to create another new catalog with the same name, as the platform is looking for the sys_id.

Log Details:

SQL16:45:05.702: Time: 0:00:00.000 for: scskswdev_1[glide.29] SELECT ... FROM (sc_catalog sc_catalog0 INNER JOIN sys_metadata sys_metadata0 ON sc_catalog0.`sys_id` = sys_metadata0.`sys_id` ) WHERE sc_catalog0.`sys_id` = '742ce428d7211100f2d224837e61036d' /*...*/
log16:45:05.704: [DefaultTranslationProvider] No db entry for: table=sc_catalog, id=742ce428d7211100f2d224837e61036d, language=en, source=sc_catalog
log16:45:05.707: null:701:86: <g2:generate_grid> java.lang.NullPointerException: java.lang.NullPointerException: com.glide.catalog.cache.impl.DefaultTranslationProvider.getFieldTranslationsFromSysTranslated(DefaultTranslationProvider.java:231) com.glide.catalog.cache.impl.DefaultTranslationProvider.access$300(DefaultTranslationProvider.java:29)

Resolution

  1. Navigate to Catalog Definitions-> Maintain Catalogs.
  2. Download the following file from attached in this Article. sc_catalog.xml
  3. Import the xml file from "Maintain Catalogs" list view.
  4. Verify if the (+) icon working at Service Catalog -> Catalogs

Related Links

It would be better to set OOTB "Technical Catalog" to inactive instead of deleting it to avoid this issue happens.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.