Issue
When configuring a custom push notification for Servicenow Mobile Agent app instead of linking to a record's detail screen, customer instead likes to navigate to a Service Portal URL (i.e. the ticket page with the table & sys_id from the record generating the notification) within the Agent app. I
Release
From ServiceNow Madrid and newer.
Cause
KB0622333 only applies for old apps and not SN Agent.
Resolution
Dynamic URLs are not yet supported in ServiceNow Mobile Agent App
As a workaround, one possible way to achieve that is by creating a url applet but it will only support static links in theory:
DocumentId in json is destination applet sys id, one possible way to achieve your use case will be:
1 - Create a url applet as the documentation to configure URL screen explains
2 - provide sys id of url applet in json as documentId.
For More info, see the product documentation topic about Mobile setup push notifications