Notifications

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Description

When configuring a custom push notification for Servicenow Mobile Agent app instead of linking to a record's detail screen, customer instead likes to navigate to a Service Portal URL (i.e. the ticket page with the table & sys_id from the record generating the notification) within the Agent app. I

Cause

KB0622333 only applies for old apps and not SN Agent. 

Resolution

Dynamic URLs are not yet supported in ServiceNow Mobile Agent App

 

As a workaround, one possible way to achieve that is by creating a url applet but it will only support static links in theory:

DocumentId in json is destination applet sys id, one possible way to achieve your use case will be:

1 - create a url applet , https://docs.servicenow.com/bundle/newyork-mobile/page/administer/tablet-mobile-ui/task/sg-configure-url-screen.html

2 - provide sys id of url applet in json as documentId.


More info:
https://docs.servicenow.com/bundle/newyork-mobile/page/administer/tablet-mobile-ui/task/sg-mobile-set-up-push-notifications.html

Article Information

Last Updated:2019-12-04 02:12:11
Published:2019-12-04