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SSO users fail to get redirected to the IDP : "SSO Provider not found or inActive at user record" - Support and Troubleshooting
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KB0787991

SSO users fail to get redirected to the IDP : "SSO Provider not found or inActive at user record"


2944 Views Last updated : Jul 24, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

  • SSO Users fail to get redirected to the SSO IDP Provider
  • In the Servicenow logon page the following error is observed: ""an error has occurred - please contact your system administrator"
  • The following error is observed in the System log "SSO Provider not found or inActive at user record:"

Cause

The SSO IDP Provider was not found.

The instance checked for the IDP to redirect to from the "SSO Source" field in the User record.

If an incorrect value is placed in the SSO Source field for the user, the issue occurs 

Resolution

In the SSO Source field, enter one of the following:

  • For SAML users, enter sso: followed by the sys_id of the identity provider's record.
  • Validate that the sys_id of the IDP record in Servicenow is the value in this field

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