Issue
NEW button on Entry points Related List on Application Services show Page not found error
Steps to reproduce:
- Open any record of Application Service [cmdb_ci_service_discovered]
- In the Entry Points related list, click NEW
- Check the pop up for error. It will show page not found error
It will look like below screenshot:
Cause
The 'New' UI acton calls upon a UI page named sa_add_connection. However, this UI page comes from a plugin named com.snc.service-mapping. It could be possible that this plugin is not installed on the customer's instance.
Resolution
This functionality is currently being investigated via PRB1459918, where we are currently expecting 2 outcomes from this PRB, based on the decisions that Development can make:
1. We allow customers without Service Mapping to use this feature
2. We remove the NEW button from the related list since customers without Service Mapping should restricted from using it
As a workaround, the customer needs to install the above plugin (com.snc.service-mapping) to get the UI page, so the proper URL will open for them to create the Entry Points. Please note that this is a paid plugin.
Related Links
The following plugins are activated automatically when the Service Mapping plugin (com.snc.service-mapping) is activated:
- Discovery (com.snc.discovery)
- Pattern Designer (com.snc.pattern.designer)
- Cloud Management Core (com.snc.cloud.core)
- Performance Analytics – Content Pack – Service Mapping (com.snc.service-mapping.pa.content)
- Event Management and Service Mapping Core (com.snc.service-watch)
More details available on: Request Service Mapping