Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
[Database View] Broken List calculations in List v2 - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • [Database View] Broken List calculations in List v2
KB0787464

[Database View] Broken List calculations in List v2


502 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

In List v2, you can configure list calculations for columns, which calculates column totals, minimums, maximums, and averages. In a list of records, right-click the header of a numeric column you want to evaluate with list calculations. Select Configure > List Calculations, and the list calculation window appears. 

The behavior reported here is specific to Database Views. The list calculation returns '0.00' as a result even when the list retrieves values bigger than '0.00'.

 

 

Comparing with an OOB instance we see the following behavior:

- Customer's instance:
<span class="aggregate_value" aggregate_type="SUM" aggregate_value="8.33333333" aggregate_field="pkg_u_monthly_cost" aggregate_display="£0.00">£0.00</span>

- In a OOB instance: 
<span class="aggregate_value" aggregate_type="SUM" aggregate_value="2799.9900" aggregate_field="pkg_u_cost" aggregate_display="£2,799.99">£2,799.99</span>

Cause

The issue here lies in records with an (empty) ID in the [fx_price] or [fx_currency] table:

 

 

Resolution

Delete the records with an (empty) ID to fix the list calculations.

Note that it's safe to delete such records since they are orphan records (not referencing any existing record). 

Related Links

For more information about List calculations, check the following documentation page: Documentation - List v2 Calculation


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.