Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Selecting the approve link in approval emails displays a blank browser screen - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Selecting the approve link in approval emails displays a blank browser screen
KB0787305

Selecting the approve link in approval emails displays a blank browser screen


8930 Views Last updated : Jun 18, 2025 public Copy Permalink English (Original)
  • English (Original)
  • Japanese
KB Summary by Now Assist

Issue

When selecting the approval link in an approval email, it no longer works and instead a blank page displays.

Following is an example of a script that contains this link:

https://<instance-name>.service-now.com/nav_to.do?uri=sysevent_email_action.do?sys_id=f1fae7b6c0a8011b004aad7f89c7d00f%26sysparm_view=advanced

This script should open the email client. Instead, the browser shows the following URL:

mailto:<instance-name>@service-now.com?subject=Re%3ACHG0046148%20-%20approve&body=%0A%0ARef%3AMSG8421705%20

 

Cause

This happens when the user's computer is configured to open mailto links with the browser instead of the email client.

Resolution

This is not a ServiceNow issue. Check with your desktop team on how to configure mailto links with the email client.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.