Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Approval functionality is not working properly after 'Refer Back' the knowledge article - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Approval functionality is not working properly after 'Refer Back' the knowledge article
KB0787283

Approval functionality is not working properly after 'Refer Back' the knowledge article


1115 Views Last updated : Sep 21, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Approval functionality is not working properly, i:e; when one of the approvers approves the article, the approval status of all the other approvers in the same assignment group is not getting changed to 'No Longer Required'.
Expected: As per approval functionality, approvals status of other approvers in the same assignment group should change to "No Longer Required" when one of the members approves. 

Cause

We see in the workflow there is an error "After running a sequence of activities we expected a 'last executing' record to predict the future stages from" and once the approval are refer back for the first time, the workflow is not moving forward as expected.

Resolution

OOB script workflowApprovalUtils is customized.
https://<instancename>.service-now.com/sys_script_include.do?sysparm_record_rows=33&sysparm_record_list=nameCONTAINSworkflow%5EORDERBYname&sysparm_record_row=13&sysparm_record_target=sys_script_include&sysparm_view=&sys_id=0360b36d0a0a0b260a89dfec60c339c4&sysparm_nostack=true

We reverted the above to OOB and created an article that is now working as expected.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.