Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Errors: "AudienceRestriction validation failed. No matching audience found sending users" to external_logout_complete.do - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Errors: "AudienceRestriction validation failed. No matching audience found sending users" to external_logout_complete.do
KB0787186

Errors: "AudienceRestriction validation failed. No matching audience found sending users" to external_logout_complete.do


13470 Views Last updated : Jul 11, 2025 public Copy Permalink English (Original)
  • English (Original)
  • Japanese
KB Summary by Now Assist

Issue

Customer reports they are not using SSO / Multi-Provider SSO yet when a user try to access ServiceNow instance in browser, user is redirected to external_logout_complete.do page stating below message on screen:

=============

Logout Succeeded

Logout Successful

You have successfully logged out.

=============

 

Release

Applicable to all releases

Cause

SSO / Multi-Provider SSO is one of the external authentication methods available and not the only one. Therefore, in this case when Multi-Provider SSO is not active, it confirms some other external authentication is active which is broken or misconfigured. System property glide.authenticate.external controls enabling / disabling external authentication.

Resolution

For a quick relief, set system property glide.authenticate.external value as false and check what other external authentication is customer using and you can fix it according.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.