Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
In Virtual Agent, customized/personalized Greeting Message topic is showing in the 'Show me everything' list of topics to pick from. - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • In Virtual Agent, customized/personalized Greeting Message topic is showing in the 'Show me everything' list of topics to pick from.
KB0786399

In Virtual Agent, customized/personalized Greeting Message topic is showing in the 'Show me everything' list of topics to pick from.


3382 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

If a user creates a custom greetings topic, it displays on the 'Show me Everything' list. 

There is a column on sys_cs_topic that controls this behavior. You can hide the topic by changing the value in the column for that particular topic. 

Release

ALL

Cause

This is caused because any custom topic that is created is automatically set to 'Is Topic Visible' to true. This column on out of Box 'Greetings' topics is set to false.

Resolution


1. In the application navigator, go to sys_cs_topic.list
2. Add the 'Is Topic Visible' column to the list.
3. Change the value to 'false' for the custom/personalized greetings topic.

This should resolve the issue.

Related Links

Select Virtual Agent setup topics.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.