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Flow is being triggered multiple times - Support and Troubleshooting
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  • Flow is being triggered multiple times
KB0786274

Flow is being triggered multiple times


9088 Views Last updated : Apr 7, 2024 public Copy Permalink English (Original)
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KB Summary by Now Assist

Issue

This KB is for Flows that are triggered on CRUD operations on any supported table 

  • The flow is being triggered more than once
  • Multiple flows are running on the same source record

Cause

  • This issue can be caused by the existence of duplicate Record Triggers for the same Flow
  • or the issue can be caused by the flow's condition being met twice on the same GlideRecord update

Resolution

  • Review the Record triggers [sys_flow_record_trigger] for the flow and check for any duplicate triggers. Deactivate the duplicate trigger


  • If the issue is NOT with the duplicate trigger records, then it could be due to the flow's condition being met twice
  • for example, if there is a condition: stage "is" fulfillment; and during the GlideRecord update it's being set twice, then the Flow will trigger twice
  • to resolve this in the example above, change the condition to: stage "changes to" fulfillment
  • Also, multiple flows triggering twice, as been determined to be a PRB; PRB1445168 - Flow has been triggered twice at the same time when two record updates happens concurrently even if the flow is configured to trigger once on update


  • if none of the above applies then it could be due to multiple [sys_trigger_runner_mapping] records, where the "identifier" column is the flow's sys_id, there should only be one of these records

Related Links

How do you link [sys_flow_trigger_plan] record back up to the flow?

  • Open [sys_flow_trigger_plan] table, the "Plan Id" field contains the flow's sys_id, and the "trigger" field contains the [sys_flow_trigger_plan] record, alternatively if the flow is based on data/time trigger then it would be a [sys_flow_timer_trigger] record

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