Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
IntegrationHub action fails with error "failed because no valid MID is available,Please check System Logs". - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • IntegrationHub action fails with error "failed because no valid MID is available,Please check System Logs".
KB0786254

IntegrationHub action fails with error "failed because no valid MID is available,Please check System Logs".


4421 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

IntegrationHub action fails with error "failed because no valid MID is available,Please check System Logs".

Release

All currently supported releases.

Cause

IntegrationHub lets you build reusable integrations with third-party systems and call them from anywhere in the platform. For example, request IntegrationHub to call external systems using integration APIs from the Action Designer Script step, run the Script step on the Mid Server, and activate protocol steps like REST, SOAP, and PowerShell.

The integration will need to determine what MID server to use, if the integration is set to use a MID server. If based on the configuration a MID server cannot be found, the error "failed because no valid MID is available,Please check System Logs" will be returned.

Resolution

  1. Review the integration configuration. If for example a http request, review the connection configured.
  2. Update the action criteria for the MID server. Alternatively, update the MID server capability, application, and ip range so that it can be found by the action.

Related Links

  • IntegrationHub
  • Introduction to credentials, connections, and aliases
  • MID Server selection

The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.