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NetScaler Load Balancers all named 'netscaler' after discovery - Support and Troubleshooting
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KB0786203

NetScaler Load Balancers all named 'netscaler' after discovery


3428 Views Last updated : Sep 13, 2022 public Copy Permalink
KB Summary by Now Assist

Issue

All of the discovered NetScaler Load Balancers have been given the name 'netscaler.'

Discovery is configured to use DNS for names, but it appears that the Netscaler Load Balancer pattern is not doing a nslookup.

System property "glide.discovery.hostname.snmp_trusted" is set to false.

Cause

Under the Pattern Designer -> Discovery Patterns menu, load the Netscaler Load Balancer pattern to review these steps:
a. It gets the name (sysName) in step 1.1 and then uses it (in 1.2) during, set the variable $formattedSysName.
b. Then it uses this variable in step six "6. Update NetScaler table" to update the name.

Resolution

1. Verify the NetScaler device 'sysName'.

Check the snmp mib and verify the 'sysName' value by logging into the device's Command Line Interface (CLI) and running the following command:

show snmp mib

2. Change the value of the 'sysName'.

Run the following command in the device's CLI to set the name of the SNMP MIB:

set mib -name <DNS_NAME or NAME_OF_THE_NETSCALER_LB>

3. Run Discovery on the device again.

Related Links

Note: When using probes and sensors and the system property glide.discovery.hostname.snmp_trusted is set to false, the system uses dns_name as the load balancer name. When using the Netscaler Load Balancer pattern, the system currently doesn't recognize this system property when it is set to false.

An enhancement request can be submitted via Ideas Portal to be able to raise the idea to the development team for consideration of future releases.

Idea Management for customer enhancement requests KB: https://support.servicenow.com/kb_view.do?sysparm_article=KB0755878


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