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Survey Link Issue - "You have completed the survey" - Support and Troubleshooting
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  • Survey Link Issue - "You have completed the survey"
KB0786152

Survey Link Issue - "You have completed the survey"


1550 Views Last updated : Jul 24, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

If fulfiller users are logged in and click on notification survey link As per sequence all steps are displaying and complete the survey successfully.

If fulfiller users are logged off (i.e., as a GUEST) and click on notification survey link (Opens in a different browser as a new session). The error message appears as  "You have completed this survey".

Release

London Patch 10

Cause

Custom email notification script for surveys and the script contained the below URL:

https://<instance-name>/assessment_take2.do?sysparm_assessable_sysid=(sysidnumber)&sysparm_assessable_type=e35fac98dbdf67407217f4eb0c9619b0&sysparm_reader_view=true

The same link leads to the survey and the customer completes the survey and then they use the same link for the survey response, therefore, the error message appears because the link is expired/taken.

Resolution

This is the OOB link for guests as an example:

https://<instance-name>/nav_to.do?uri=assessment_take2.do%3Fsysparm_assessable_type=87186844d7211100158ba6859e610378. 

You will not be able to access this link, but if you take a closer look at this it does not include "sysparm_assessable_type record".

You will have to modify the URL for guests to solve the issue.


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