Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
After Submitting a HR case on the Service Portal the HR Case information is not Visible for certain users. Record Not Found - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • After Submitting a HR case on the Service Portal the HR Case information is not Visible for certain users. Record Not Found
KB0786132

After Submitting a HR case on the Service Portal the HR Case information is not Visible for certain users. Record Not Found


2057 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Submit an HR Case through HR catalog on the ESC portal. After the Case submission, the HR case information is not visible on the portal.  For admins and some users, it is working.

Release

New York Patch 1 Hot Fix 1a

Cause

Once the HR case is submitted or while accessing the record from the platform, there is a query Business Rule on customer instance which has a custom script causing the issue.
https://********.service-now.com/sys_script.do?sys_id=1468d300db7844d09cf2553c689619ce&sysparm_view=&sysparm_domain=null&sysparm_domain_scope=null&sysparm_record_row=1&sysparm_record_rows=2&sysparm_record_list=collection%3dsn_hr_core_case_total_rewards%5eORcollectionINsn_hr_core_case_total_rewards%2csn_hr_core_case%2ctask%5eaction_query%3dtrue%5eORDERBYname

Resolution

After disabling the mentioned Query Business Rule, we could see the user is able to access the HR record.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.