Notifications

14 views

Description

Customer query:

I have a scheduled job on DEV and QA that works perfectly, but PROD is not working.

Can you help me identify where the problem is?

Scheduled jobs in the QA environment that works: "Some Global Job Name that is working" https://someinstance.service-now.com/nav_to.do?uri=%2Fsysauto_script.do%3Fsys_id%3D0cd706ccdb0944106cbe09a0ba96194d%26sysparm_view%3D%26sysparm_domain%3Dnull%26sysparm_domain_scope%3Dnull%26sysparm_record_row%3D1%26sysparm_record_rows%3D1%26sysparm_record_list%3DnameSTARTSWITHCriar % 2BRITM% 255eORDERBYname

 

Scheduled jobs in the PROD environment that is not-working: "Some Global Job Name that is not working" https://someinstance.service-now.com/nav_to.do?uri=%2Fsysauto_script.do%3Fsys_id%3D0cd706ccdb0944106cbe09a0ba96194d%26sysparm_view%3D%26sysparm_domain%3Dnull%26sysparm_domain_scope%3Dnull%26sysparm_record_row%3D1%26sysparm_record_rows%3D1%26sysparm_record_list%3DnameSTARTSWITHCriar%2Britm%255eORDERBYname Thanks!

 

Note: sys_ids are identical:  0cd706ccdb0944106cbe09a0ba96194d  This means object was copied to PROD with the expectation it should work similarly as in DEV/QA.

Release or Environment

All Releases and ENVs

Cause

Production instances cannot be used as the target instance for a clone after the instance is live. Moreover copying (importing) an object to PROD from DEV/QA not best practice.

Resolution

[code]Work around/ Fix : [/code]
Solution: Re-create scheduled job in PROD.
Please see creating schedule jobs
https://docs.servicenow.com/bundle/madrid-platform-administration/page/administer/time/task/t_CreateAScheduledJob.html
Steps:

1. Navigate to System Definition > Scheduled Jobs.
2. Click New.

Article Information

Last Updated:2019-12-05 01:16:29
Published:2019-12-05