Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Global search returns incorrect count of result on search group - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Global search returns incorrect count of result on search group
KB0785224

Global search returns incorrect count of result on search group


553 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Sometimes on doing a global search, correct results and count gets displayed in the main results tab but incorrect count on search groups in the right tab "What's on the page".

For example in below screenshot, the search results gave [Incidents(9) and Project(0)] in main tab while in right tab [Incident(0) and Project(9)]

Release

Any Release

Cause

This is due to same order on search tables in search group which cause wrong count to be displayed for search groups. Each search table in the search groups should have different order.

Resolution

To resolve the issue change the order of search tables with same order.Follow steps given below:

Steps

1. Navigate to search groups
2.Open search group which contains the affected search table
3. Change the order of tables with same order to different values
4. Save

Observe that same result count gets displayed in the main results tab and the right tab "What's on the page"


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.