Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Connector instance stuck in running state for 2 hours. - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Connector instance stuck in running state for 2 hours.
KB0785101

Connector instance stuck in running state for 2 hours.


974 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Customer reported that one of the connector instance is stuck in running state for two hours before being erred out.

Cause

  • OOB, when a connector instance is executed, a ConnectorProbe is created for the targeted MID Server.
  • If the MID Server goes down, its corresponding record in "ecc_agent" table is updated as "Down".
  • This triggers a Business Rule "Update connectors". The Business Rule update all executing ConnectorProbe on the problematic MID Server to "processed". It also update the connector instances being executed by the MID Server to not running. This would allow next execution of the connector instance to proceed if multiple MID Servers are configured or MID Server is in a cluster.
  • To find the executing connector instances, the Business rules queries the "em_connector_instance" table whose name is the same as the ConnectorProbe's source (ecc_queue.source field). The first matching record is updated to not running.
  • Customer has several connector instances with the same name so the query pulled up multiple connector instances. Depending on the order of the list the DB returned, the first matching record could be the wrong connector instance. This was the case. The intended Connector instance was not updated leaving it in the running state.
  • Two hours later the "Event Management - Update Stuck connectors" scheduled job determined that the connector instance is stale and erred it out.

Resolution

Correct the connector instances names and make sure they are unique.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.