Issue
Requested item stage values are not showing on list view when there is an flow designer attached to the item
Cause
Stages on the flow designer are not imported/added
Resolution
- For a stage field to report stages on a record-based flow, a stage field must be present on the same table as the triggering record.
- Import the stages to the flow designer and add them next to the actions will solve the issue.
- Please see the below documentation URL to know more about the configure stages and adding them to the flow designer
- Configure stages and add them to flow