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User with the snc_external role is receiving a "404 page not found" error when trying to displayed a non public Service Portal page when User Criteria is enabled - Support and Troubleshooting
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  • User with the snc_external role is receiving a "404 page not found" error when trying to displayed a non public Service Portal page when User Criteria is enabled
KB0784588

User with the snc_external role is receiving a "404 page not found" error when trying to displayed a non public Service Portal page when User Criteria is enabled


3774 Views Last updated : Jul 24, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

An end-user with only the snc_external role receives a "404 page not found" error when trying to display a nonpublic service portal page. However, the page has the scn_external role under the Roles field.

Cause

If a Service Portal page is not public, users with the snc_external role won't be able to see it. So the role needs to be added in the Roles field of the page. But if User Criteria is configured, the Roles field is not displayed.

Resolution

If User Criteria is configured, then the Can View and Cannot View TABs (Related Lists) will be displayed in the page and the Roles fields will not be displayed. So the options to include roles for the pages are:

OPTION 1

  1. Go to Service Portal > Properties
  2. Type snc_external under "List of roles (comma-separated) that bypass User Criteria validation in Service Portal."

OPTION 2

  1. Under the "Can View" tab, add the snc_external role or group that contains the snc_external role.

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