Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
On list filter condition, choice filter showing as 'None' after running the query - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • On list filter condition, choice filter showing as 'None' after running the query
KB0784412

On list filter condition, choice filter showing as 'None' after running the query


1430 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Fields like Category or Subcategory fields have many choices. when these fields are used in list condition builder by giving a specific condition like 'Category is Hardware' and run the filter you may observe filter breadcrumb changed to 'Category=Hardware' and on expanding the filter condition shows as 'Category is None'.

Cause

This is due to 'Label' and 'Value' of choice is ending with a space character at the end of the text.

This is causing the query no to recognize the filtered term and showing 'None' in condition builder and corresponding choice field column in the list may also show text in 'blue' color.

Resolution

To fix this issue, remove the extra space character at the end of the 'Label' and 'Value' for the affected choices.

Example:

Affected choice field have space character at the end

Label: 'Hardware '

Value: 'Hardware '

Clear the space character and save the field which will resolve the issue and query will not return None value.

Label: 'Hardware'

Value: 'Hardware'


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.