Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Numbering is increased every time a record is opened. - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Numbering is increased every time a record is opened.
KB0784242

Numbering is increased every time a record is opened.


1796 Views Last updated : Aug 24, 2022 public Copy Permalink
KB Summary by Now Assist

Issue

Every time a Contract record is opened, the Counter of the number will be increased. This leads to gaps in numbers and increased numbers very quickly.

Cause

Upon investigation, I found that this is happening due to the Embedded List for Contract records under the "Contracts" tab of your form.
Out of the Box, when new records are created the numbering is increased by 1 even when not fully saved. The same case applies to Embedded Lists.

To fix this, we have two options. We can remove the Embedded List from the form or if you want to keep it there, we have a System Property to enforce the next number to be used without any gaps.

Resolution

The steps for both options are below.

NEXT STEPS (Remove Embedded List):

1. Navigate to Contract > Contracts > All
2. Open any record
3. Right-click the form header and go to Configure > Form Layout
4. Look for the "Form view and section" area and go to the "Contracts" section
5. Remove "Contract->Parent contract" from the selected list
6. Click Save

NEXT STEPS (System Property):

1. Navigate to System Properties > All Properties
2. In the Name column, search for "glide.itil.assign.number.on.insert" and go to the record
3. Set the Value field to "true"
4. Save the record


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.