Issue
Unable to search for the 2nd column of a List Collector variable in Service Portal
Release
Any Release
Cause
It is caused due to the underlying table of that column not being indexed to enable text search
Resolution
-Goto sys_dictionary entry of the table which being accessed by the list collector variable to display the values
-Observe that Text index checkbox is unchecked.
-To index the table click on the text index checkbox and update the record
-Then click on the link "Generate Text Index" to index the table
Related Links
Refer docs link below for text indexing: