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KB Articles not able to be retired. - Support and Troubleshooting
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KB0783705

KB Articles not able to be retired.


937 Views Last updated : Jul 24, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

We have a number of imported documents that do not respond to the retire button.

Cause

Knowledge base does not have Owner or valid managers.

Resolution

The behavior seen is because the knowledge base does not have owner or valid managers. Please see the knowledge base record on the Knowledge base (kb_knowledge_base) table. In the top right corner you will see the Knowledge owner field is empty. This is a mandatory field out of box and should be populated. Also, please note the manager field is showing SYS IDs and not user names. This is because these sys ids do not belong to any users in this instance. 

The approval retire process which is currently set on articles in this base require approvers. The approvers are pulled from both the Owner field and the Manager fields. As these fields do not hold valid users, the workflow skips the approval and retire activities and closes out. The solution is to add valid users to both the Owner and Manager field of the knowledge base, or at minimum the Owner field.


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