Issue
When you select Run Discovery on a Service Map, the "Starting discovery" message appears briefly and then disappears. The discovery process does not begin.
Release
Any supported release
Cause
Service Mapping checks the sa_endpoint_status table to count active discovery jobs before starting new ones. Discovery will not start if the number of running jobs exceeds the limit set by:
- The sa.max_concurrent_service_discovery_tasks system property (if configured)
- 100 jobs (the default limit when the property is not set)
This limit prevents system performance issues.
Resolution
This issue may be caused by a large map that's being discovered.
To resolve the issue, follow these steps:
Check active discovery jobs.
- Go to Service Mapping > Services > Application Services.
- Filter results by Discovery Status not equal to Done.
- Review which services are currently being discovered.
- Check the sa_endpoint_status table for records not in a Completed state.
Optimize large service maps.
- Review large maps and mark unnecessary connections as boundary to exclude them from discovery.
- See the documentation, Remove CIs not belonging to application services
Additional resolution options
- Halt discovery on large maps that are currently running.
- Change service discovery to run during off-peak hours.
- Increase the concurrent task limit. To do this:
- Create or update the sa.max_concurrent_service_discovery_tasks system property and set it to the expected value.
- Default is 100. Increasing this will have an impact on performance.
- Optimize batch processing. To do this:
- Create or update the sa.rediscovery.batch_size system property to 150.
- Default is 100. This makes Mapping Discovery faster but sacrifices some in performance.