Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Service Mapping Discovery does not start / initialize - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Service Mapping Discovery does not start / initialize
KB0783641

Service Mapping Discovery does not start / initialize


1500 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

When clicking on "Run Discovery" button on a Service Map, the "Starting discovery" message pops for a few seconds, then disappears. Discovery does not seem to start.

Cause

After clicking on "Run Discovery" button on a service map, the Service Mapping engine checks sa_endpoint_status table to see how many jobs are running.

If count of jobs is more than the value of system property "sa.max_concurrent_service_discovery_tasks" (if set), or 100 (if the property not set), then discovery won't start.

 

Resolution

This issue may be caused by a large map that's being discovered.

You can check sa_endpoint_status to see the count of records that are not in Completed state.

You may open Service Mapping > Service > Application Services, then filter result with "Discovery Status" not Done to confirm which Service is still being discovered.

Review the large map, and mark unnecessary connections as "boundary" so they won't be discovered - check below doc:
Remove CIs not belonging to application services

Other options are:

1> Stop Discovery on the large map that's running
2> Change service discovery schedule starting time to after hours
3> Create or update system property sa.max_concurrent_service_discovery_tasks and set it to expected value (default is 100, increasing this will have impact on performance)
4> Create or update system property sa.rediscovery.batch_size to 150 (this will make Mapping Discovery faster with sacrifice of a bit performance, default is 100)


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.