Issue
When users login to the agent mobile app, the following exception is seen the system logs.
table name cannot be null: java.lang.IllegalStateException: Table name cannot be null: com.glide.db.TableDescriptor.(TableDescriptor.java:83)
com.glide.db.TableDescriptor.get(TableDescriptor.java:88)
com.glide.sg.internals.ItemView$Builder.(ItemView.java:94)
com.glide.sg.internals.screens.ScreenDependencies$Builder.buildItemViews(ScreenDependencies.java:231)
Release
New York and above.
Cause
This is caused by the records in sys_sg_item_view which are missing data items. Data item field on the sys_sg_item_view table is a mandatory field.
Resolution
Fix the records having the empty data item.
1) Navigate to sys_sg_item_view table and filter for records with empty data item.
https://INSTANCENAME.service-now.com/sys_sg_item_view_list.do?sysparm_query=data_item%3DNULL
2) Update the records with a data item.