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Agent Workspace notification not being triggered for agent - Support and Troubleshooting
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  • Agent Workspace notification not being triggered for agent
KB0783011

Agent Workspace notification not being triggered for agent


3110 Views Last updated : Jun 1, 2023 public Copy Permalink
KB Summary by Now Assist

Issue

Agent Workspace UI notification defined on incident record as shown below, but the agent was not getting the notification.

Screenshot of UI Notification Trigger form. The form has all the fields populated: Table is incident, Active is selected, Under the "Who will receive" tab, Users field, the value is: dollar sign, and assigned_to in curly brackets

Release

Newyork release.

Cause

The "notification_trigger" record was not triggered for agent user because the "Assigned to" field is empty on the incident record but the "UI Notification Trigger" was looking to deliver it to "assigned to" user.

Resolution

  • Please update the incident record with "assigned to" = <Agent name>, then agent user will get a notification on agent workspace when the same incident record is updated by another user. OR
  • Update the "ServiceRequest-Notifications" notifications "who will receive" fields with other options than "assigned to" field.

Related Links

Agent workspace notification

Note: there is an expected limitation to this functionality - Conversation audio alerts do not work in legacy workspace unless you are focused on the inbox tab.


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