Issue
There can be a few reasons as to why the name of a CI is not updated as expected after discovery, even though the payload has the correct host name. Please review the below possible causes:
Cause
- Check if there are any reconciliation rules defined for the name field of the CI class using "CI Class Manager"
- Review the system properties for the following properties to make sure they are not preventing the host name from being updated:
- glide.discovery.hostname.always_update
- glide.discovery.hostname.dns_nbt_trusted
- glide.discovery.hostname.wmi_trusted
- glide.discovery.hostname.snmp_trusted
- glide.discovery.hostname.ssh_trusted
- Check the CMDB table to make sure there are no custom business rules which could prevent the name from being updated. Sometimes, customers create a business rule to prevent duplicate CI names.
Resolution
Please review the above information for possible causes to investigate the issue.