Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
PostgreSQL Pattern detecting the default running instance for 'hostname' - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • PostgreSQL Pattern detecting the default running instance for 'hostname'
KB0781629

PostgreSQL Pattern detecting the default running instance for 'hostname'


395 Views Last updated : Jan 16, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

During a discovery it creates and updates CMDB records when it detects a running instance at the PostgreSQL level.

Per our docs it collects the name PostgreSQL instance@hostname. However, as by default we see in the related tree of several CIs with 'PostgreSQL' with in the cmdb_ci_db_postgresql_instance table.

Cause

Out of box we see this:

Step 19. Set label

Value: $instance 
Name: $name

This is the Output example:
'PostgreSQL'

In the related tree of the CI we see there are several PostgreSQL, listed in the cmdb_ci_db_postgresql_instance.

 

Resolution

Do the following if you prefer to have the PostgreSQL pattern to populate the PostgreSQL@instance name.

Step 19. Set label
added the following:
Value: $instance + "@" + $computer_system.primaryHostname
Name: $name

This is the Output example:
'PostgreSQL@mikecamba'

 


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.