Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Agile Sprint Planing Tab is not working - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Agile Sprint Planing Tab is not working
KB0780913

Agile Sprint Planing Tab is not working


662 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Upon migration from Agile 1.0 to 2.0, "Sprint Planning" tab is unresponsive

Release

Any Patch

Cause

While we click on the "Sprint Planning" tab, we can see the below error in the browser console,

 {"error":{"message":"Cannot convert null to an object.","detail":"TypeError: Cannot convert null to an object. (sys_script_include.d8db4ec05b26030036c32c1cf0f91aca.script; line 22)"},"status":"failure"}

In the script include "SprintPlanningMetaDataService" we see that the below line of code checks for the Planned Start/End dates on the Sprint,

                  var startDate = sprint.start_date.getGlideObject().getLocalDate().getDisplayValue();

                  var endDate = sprint.end_date.getGlideObject().getLocalDate().getDisplayValue();

The above script basically do a glide record on the rm_sprint that is "Sprint" table and check if a sprint associated to an Agile group has the planned start/end dates while displaying the content.

Resolution

Entering the Planning Start/End dates for the Sprints associated to an Agile group would fix the issue.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.