Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Data Source Type File fails with error "com.glide.db.impex.datasource.DataSourceException: org.apache.poi.poifs.filesystem.OfficeXmlFileException: The supplied data appears to be in the Office 2007+ XML ..." - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Data Source Type File fails with error "com.glide.db.impex.datasource.DataSourceException: org.apache.poi.poifs.filesystem.OfficeXmlFileException: The supplied data appears to be in the Office 2007+ XML ..."
KB0780856

Data Source Type File fails with error "com.glide.db.impex.datasource.DataSourceException: org.apache.poi.poifs.filesystem.OfficeXmlFileException: The supplied data appears to be in the Office 2007+ XML ..."


9909 Views Last updated : May 1, 2024 public Copy Permalink English (Original)
  • English (Original)
  • Japanese
KB Summary by Now Assist

Issue

- During the execution of the Data Source following error is reported

com.glide.db.impex.datasource.DataSourceException: org.apache.poi.poifs.filesystem.OfficeXmlFileException: The supplied data appears to be in the Office 2007+ XML. You are calling the part of POI that deals with OLE2 Office Documents. You need to call a different part of POI to process this data (eg XSSF instead of HSSF)

- Data Source is configured as: Type=File, Format=CSV, File Retrieval Method=Attachment

Cause

Data Source was previously configured with "File Retrieval Method=SCP" and the value for "File Path" was not removed before the Retrieval Method was changed to Attachment. As "File Path" is not an expected parameter for Attachments then it fails. Use "Show XML" of the record to confirm the value for "File Path"

Resolution

Remove the value for parameter "File Path" as follows:

1.. Go to Data Source record

Example: https://<instance_name>.service-now.com/nav_to.do?uri=sys_data_source.do?sys_id=XXX

2. Change the "File retrieval method" to SCP

3. Remove the values for field "File path"

4. Revert the "File retrieval method" to Attachment and save the record

5. Verify the results using "Test Load 20 Records"

Related Links

Data Sources
https://docs.servicenow.com/csh?topicname=c_DataSources.html&version=latest


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.