Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
ATF Field State Validation Step Failure: "Expected field 'field_name' to be visible but it was not visible." - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • ATF Field State Validation Step Failure: "Expected field 'field_name' to be visible but it was not visible."
KB0780152

ATF Field State Validation Step Failure: "Expected field 'field_name' to be visible but it was not visible."


859 Views Last updated : Jul 24, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

While running ATF test, the 'Field State Validation' Step for the 'work_note' field fails with the following error:

"FAILURE: Expected field 'work_notes' to be visible but it was not visible. See screenshot"


Cause

The field can only evaluate correctly for fields handled by Data Policy. The error is issued when there is ACL rules to make the field read only.

Resolution

Deactivate the read ACL for field that is stated in the error message.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.