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Cannot see list of Configuration Items on Change Request or any Task form. - Support and Troubleshooting
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  • Cannot see list of Configuration Items on Change Request or any Task form.
KB0780144

Cannot see list of Configuration Items on Change Request or any Task form.


2033 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Unable to see list of Configuration Items in the Configuration Item reference field in Change Request or any task form.

Release

All releases

Cause

Dependent field has "company" in the the dictionary entry of the cmdb_ci field in the "Dependent Field" tab: https://<instance_name>.service-now.com/nav_to.do?uri=sys_dictionary.do?sys_id=035f6df0db002200947ffbf9af961917%26sysparm_view=advanced

Resolution

1. By default, the Configuration Item field is dependent on the "Company" field of the task record. This means, the field will only show CI values if the company of the task (incident or change) matches the company of the CI record.
2. You can see this setting in the dictionary entry of the cmdb_ci field in the "Dependent Field" tab: https://<instance_name>.service-now.com/nav_to.do?uri=sys_dictionary.do?sys_id=035f6df0db002200947ffbf9af961917%26sysparm_view=advanced
3. You will be able to see the CIs for change requests which have "Company" field empty, in which case, all CIs are displayed. 
4. If you do not wish to have this functionality, simply remove the dependent field value which is "company" from here: https://<instance_name>.service-now.com/nav_to.do?uri=sys_dictionary.do?sys_id=035f6df0db002200947ffbf9af961917%26sysparm_view=advanced
OR
If you do not wish to have this functionality for change_request table, Update the dictionary override of the cmdb_ci field for change_request table by checking the Override dependent box. This will ignore the dependent field for change_request records only but will work for other tables. - https://<instance_name>.service-now.com/nav_to.do?uri=sys_dictionary_override.do?sys_id=3f45658fcb102200dff9b9c0c24c9c7c%26sysparm_view=advanced
OR
Make sure the company of the cmdb_ci and the change_request record is the same.


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