Issue
Audit tables are taking a lot of time to load and the transaction gets canceled
Release
ALL
Cause
Audit tables generally will have huge records and hence will take a lot of time to load the complete list
Resolution
Whenever you want to load the audit tables; for e.g. sys_audit table, append the parameter "sysparm_filter_only=true" at the end of the URL so that the table will be loaded immediately with empty records with filter condition showing as ALL.
Below is the sample link with the appended parameter "sysparm_filter_only=true"
https://instancename.service-now.com/sys_audit_list.do?sysparm_filter_only=true
After the table is loaded, try to give as many filter conditions so that less number of records are fetched. If the records are huge, then again there is a chance of transaction cancellation. Administrators can configure the behavior of the transaction cancel capability using the following properties.
Property | Definition | Location |
---|---|---|
com.glide.request_manager.active | Let users cancel long-running transactions (enabled by default). | Open the sys_properties table. |
glide.ui.transaction.long_response.time | Delay in seconds before the cancel transaction button appears for a long-running transaction. | Navigate to System Properties > UI Properties |
Related Links
You can also refer the documentation Transaction cancellation