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Description

This article explains how to change connect support duration calculation based on the time an agent worked on the chat rather than total time of the entire chat since it is created.

Cause

This is an implementation which requires modification of OOB business rule SNC - Chat Queue Entry Duration - https://<instance-name>.service-now.com/nav_to.do?uri=sys_script.do?sys_id=23b178d39f230200d5f9b3e2957fcfad

 

Resolution

If the duration time has to be based on the time an agent worked on the chat rather than total time of the entire chat since it is created, the Business Rule has to be modified to get the time stamp of the last comment(by using current.comments.changes()) and find the difference between that and the time at which the chat queue entry record changed it's state from New to Work In Progress.

Article Information

Last Updated:2019-09-19 18:20:15
Published:2019-09-20