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Language picker not showing on "Public Survey" Service portal page in other language than English - Support and Troubleshooting
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KB0779280

Language picker not showing on "Public Survey" Service portal page in other language than English


782 Views Last updated : Jul 24, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

After launching the public survey URL and changing the language to any other than the default English, the language picker is not available for the user anymore.

Release

Madrid, New York

Cause

When you activate a specific language plugin, for example, Finnish, the system will create entries in the sys_choice table:

  • Table: sys_user
  • Element: preferred_language
  • Language: fi
  • Value: <different other languages plugins activated on the instance>

For example, when you have the Finnish plugin activated, you have default English and Finnish languages on your instance. You should have more than one entry in sys_choice list for table=sys_user, Element=preferred_language, language=fi. If you are affected by this issue, there will only be one active entry, all others are de-activated.

Due to this, the out of the box script include "SPSurveyAPI" logic fails because it sees only one active entry for language=fi and it hides the language picker. This script include is invoked from the "Take Survey" widget.

Resolution

  • Set Inactive=false for the deactivated entries in sys_choice list for sys_choice list for table=sys_user, Element=preferred_language, language=fi, so that out of the box "SPSurveyAPI" script include logic can pass and show the language picker for Finnish language user.
  • This logic applies to other languages activated on the instance as well.

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