Issue
Users with sn_hr_le.case_reader are not able to see SLA timeline on HR life cycle records.
Release
London and above
Cause
This is expected behavior as SLAs are viewable only if the user has the ITIL role.
Resolution
There are 3 possible solutions for this:
- The HR admin can decided if they want to provide the ITIL role to the users (This will allow the users to see data from any table within the scope of ITIL change, problem, incident, etc)
- Create an ACL that only allows the users with the sn_hr_le.case_reader to see the SLAs that correlate with the HR life cycle record
- Create a before query business rule that will only allow the user with sn_hr_le.case_reader to see the SLAs that correlate with the HR life cycle record