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Description

When attaching an article to the incident form via the Attached Knowledge related list, use_count isn't updated.

Steps to Reproduce:

1. Open kb_knowledge and kb_use tables.
2. Observe use_count of an article.
3. Open an incident.
4. On Attached Knowledge tab, click Edit.
5. Attach article from step 2.
6. Observe use_count value hasn't increased.

 

Cause

This is expected behavior.

Resolution

The best practice is to attach the articles by clicking on the "knowledge search" next to short description and then click on "Attach to incident" or enable the Contextual Search on short description and attach the articles to the incident. Doing so causes the following to happen:
1. When the KB article is attached to the incident, the KB article link is visible in the Related Records related list Attached Knowledge section
2. The business rule "Create m2m_kb_task record on attach" is triggered which calls the script include - KnowledgeAjax
3. The script include has the code which triggers the event - KB Use which creates the record in the kb_use table and updates the use count

Currently, these events don't happen when a knowledge article is directly added via the Attached Knowledge related list.

Article Information

Last Updated:2019-09-18 10:32:26
Published:2019-09-17