Issue
Unable to see Social Q&A questions. Can only see the questions when viewing the Questions related list on platform.
Cause
As per the doc here https://docs.servicenow.com/csh?topicname=p_KnowledgeManagment.html&version=latest:
"Social Q&A uses the Contextual Search feature to generate search results."
You need to modify the active/applicable knowledge Search Context to now include Social Q&A.
Resolution
- Navigate to Search Contexts
2. Click on the active/applicable knowledge search context (ex. Knowledge Base Search)
3. Click the magnifying glass next to the Searcher field
4. Select a searcher that contains 'Social Q&A' (ex. Knowledge, Social Q&A and pinned)
5. Save the record