Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
I recieve a SQL Error when opening a record which has the changes to option configured in the filter - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • I recieve a SQL Error when opening a record which has the changes to option configured in the filter
KB0778962

I recieve a SQL Error when opening a record which has the changes to option configured in the filter


656 Views Last updated : Apr 19, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

When I open a record which contains a filter using changes to I receive a SQL exception such as the SQL illustrated below:

Example:

Business rules that use the ChangesTo operator in the Query Builder receive the error : Error MessageSyntax Error or Access Rule Violation detected by database (You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'CHANGESTO 

Release

All releases

Cause

There is a record count on the filter. Changes to is not a valid option which can be used with a record count. 

Resolution

1) Right click on the filter condition field on the form and select configure dictionary

2) Review the attributes and configured on this dictionary record and remove the attribute "how_condition_count=true"


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.