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Description

Caller field on the incident form refers to the user table with ‘company’ field on the incident form as a dependent field. When creating the child incident by clicking the “create child incident” UI action in the context menu, it opens a new incident form, copies all the parent fields.
Madrid OOTB behavior: when we are trying to select the user in the caller field from the popup, it is filtering the users according to the value in the company field which is expected. But, it behaves the same way and filters are applied to the user table according to the value in the company field even if the ‘company’ field is not available on the form.
Kingston OOTB behavior: when clicking on 'Create child incident', Caller field will display only users related to the Parent incident caller's company only if the company is on the form and if the company is not on the form the Caller field will display all the users.

Release or Environment

Madrid

Cause

The behavior on Madrid is the correct one as it considers the dependency of the fields irrespective of the field being visible on the form or not. The old behavior which is on the Kingston is flawed.
There is no property available to achieve the scenario that is in Kingston.

Resolution

If you would want to use the Kingston functionality in the Madrid environment below is a suggestion to achieve it:
When creating the child incident to see all users list without any filter, we can remove the company as a dependent defined in caller_id dictionary and can manage the filter with the help of a reference qualifier.
From the advanced reference qualifier, can call script include where you can code required query to pass into the caller_id field.

 

Article Information

Last Updated:2019-11-18 17:57:46
Published:2019-11-19