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Unable to attach files to HR Case (sn_hr_core_case) in specific instance, but able to in all others. Why? - Support and Troubleshooting
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  • Unable to attach files to HR Case (sn_hr_core_case) in specific instance, but able to in all others. Why?
KB0778529

Unable to attach files to HR Case (sn_hr_core_case) in specific instance, but able to in all others. Why?


1214 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

When the user attempts to attach a file to a HR Case, the modal shows that is attempting to attach. However, then, the modal just returns to being blank as if no attempt was made to attach a file. Also, no attachment is shown in the header of the HR Case.

Cause

The "Read" operation ACL for sys_attachment for HR Core has been customized and is now broken.

Resolution

As mentioned above, the read ACL for sys_attachment in the HR Core scope was modified by a non-ServiceNow user.

Reverting this ACL back to the Out of Box (OOB) version resolves the issue. For convenience, here is a link to the ACL:

    • /sys_security_acl_list.do?sysparm_query=nameSTARTSWITHsys_attachment%5Esys_package%3Dd4ac3fff5b311200a4656ede91f91af2%5Eoperation%3Dread

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